Системные требования для OpenCart

Вводная часть

Чтобы скрипт OpenCart работал правильно и магазин, созданный на OpenCart, был общедоступным в Интернет, необходимо чтобы сервер установки соответствовал определенным системным требованиям.

Системные требования для установки OpenCart

Решив использовать OpenCart для создания Интернет-магазина, вы должны проверить, чтобы выбираемый сервер размещения скрипта магазина, соответствовал предъявляемым системным требованиям.

Только сервер с необходимым программным обеспечением позволит корректно установить скрипт, правильно ему работать и задействовать все его возможности.

Выбрав сервер неподходящий под системные требования OpenCart, вы обязательно получите проблемы при установке или работе скрипта.

Именно по этому, выбор сервера по программному обеспечению, является приоритетным, по отношению к цене и месту размещения сервера.

Вместе с этим, системные требования для OpenCart не являются завышенными и подавляющее большинство серверов им соответствует. Несмотря на это, проверку соответствия нельзя игнорировать.

Системные требования для OpenCart 3

При выборе сервера для установки OpenCart 3 вам нужно проверить следующие характеристики сервера:

Программное обеспечение сервера должно использовать веб-сервер, желательно Apache. Работают сборки Nginx+Apache. Для корректной работы OpenCart на «чистом» Nginx потребуется серьёзная настройка самого сервера для корректной работы ЧПУ OpenCart.

Это может вас заинтересовать:  ЧПУ Opencart 3 — как включить, настроить, управлять

OpenCart работает с интерпретатором PHP от версии 5.4 и выше. Работа на PHP 7.0, 7.1 не требует дополнительных настроек. Пока нет данных о корректной работе OpenCart на PHP 7.2.

Скрипт работает с любой базой данных, но для беспроблемной работы скрипта не требующей дополнительных настроек рекомендован сервер базы данных MySQLi.

Перечисленные требования достаточно стандартны и вы без труда найдете сервер с Apache, PHP 5.4+ и  MySQLi. А вот требуемые модули и библиотеки PHP, возможно придётся включать самостоятельно или простить об их включении суппорт хостинга.

Для установки и корректной работы OpenCart необходимо включение следующих модулей PHP:

  • Curl: служебная программа командной строки;
  • ZIP: расширение которое позволяет читать и записывать сжатые ZIP-архивы и файлы в них;
  • Zlib: модуль возможности сжатия передаваемых страниц;
  • GD Library: программная библиотека для динамической работы с картинками;
  • Mcrypt: библиотека шифрования;
  • Mbstrings: заставляет работать PHP-приложение во много байтовом окружении. Не работает на PHP 7.2;
  • Xml:  модуль позволяющий совершать операции с элементами и атрибутами XML-документа.
Это может вас заинтересовать:  Общие настройки OpenCart: первые настройки интернет-магазина

Вышеупомянутые расширения PHP должны быть доступны почти у всех хостинг-провайдеров. Более того, вам не обязательно проверять их включение до установки системы. Во время процесса установки система сама проверит включение этих модулей и сообщит вам об этом на втором окне установки. Если какой либо модуль будет не активен, вы можете включить его самостоятельно или обратиться к своему провайдеру хостинга.

Как включить модули PHP в панели DirectAdmin

Если ваш провайдер позволяет вам самостоятельно менять версию PHP и включать/выключать модули PHP вам повезло, и включение этих модулей не займёт больше минуты.

В статье Установка OpenCart, я показал, как система показывает неготовность программного обеспечения к установке и как быстро это исправляется.

Здесь покажу, как включить модули PHP в панели DirectAdmin.

  • Авторизуйтесь в панели DirectAdmin своего хостинга;
  • Откройте домен своего магазина;
  • Вам нужна вкладка «Select PHP version»

Select PHP version

  • Далее все просто, ищите нужный модуль и включаете его;
  • После сохранения изменений возвращаетесь к установке OpenCart.

Select PHP version

Второй экран установки должен выглядеть так: все системные требования для OpenCart должны быть с зелеными галочками.

Это может вас заинтересовать:  Способы оплаты на OpenCart по умолчанию

Окно 2 установки OpenCart

Вывод

Вместо вывода перечислю системные требования для OpenCart 3 списком:

  • Apache;
  • PHP 5.4+, не выше PHP 7.1;
  • MySQLi;
  • Curl;
  • ZIP;
  • Zlib;
  • GD Library;
  • Mcrypt;
  • Mbstrings;
  • Xml.

©shopiweb.ru

Похожие посты:

(Статью прочитали: 2 443 раз)

Добавить комментарий